Forums temporarily locked down! Please read!

Author Topic: anyone seeing any issues after upgrading to El Capitan?  (Read 22353 times)

mayersj1

  • H4X0r
  • ****
  • Posts: 14
    • View Profile
anyone seeing any issues after upgrading to El Capitan?
« on: September 30, 2015, 11:17:53 PM »
Noticed that Espionage wasn't showing up in my menubar after updating to El Capitan today.  The process showed up as running in Activity Monitor, but I'm unable to interact with it.

Any issues that I missed in the forums or blog?

Thanks,

zsolt

  • Global Moderator
  • Veteran
  • *****
  • Posts: 823
    • View Profile
Re: anyone seeing any issues after upgrading to El Capitan?
« Reply #1 on: October 01, 2015, 06:54:20 PM »
Hello our testings so far showed no problems.

Try to login with guest account and launch Espionage see if that will make it show up...

Thanks

Zsolt
Follow @espionageapp on twitter for news! | For general Mac support, please visit Mac Me Support

mayersj1

  • H4X0r
  • ****
  • Posts: 14
    • View Profile
Re: anyone seeing any issues after upgrading to El Capitan?
« Reply #2 on: October 01, 2015, 06:56:09 PM »
All is working now. Oddly enough a second reboot fixed the issue. Thanks!

zsolt

  • Global Moderator
  • Veteran
  • *****
  • Posts: 823
    • View Profile
Re: anyone seeing any issues after upgrading to El Capitan?
« Reply #3 on: October 01, 2015, 06:59:05 PM »
If not the second, then the third :-), just a joke.

Thanks for letting me know.

Rgds
Zsolt
Follow @espionageapp on twitter for news! | For general Mac support, please visit Mac Me Support

wimax

  • Newbie
  • **
  • Posts: 2
    • View Profile
Re: anyone seeing any issues after upgrading to El Capitan?
« Reply #4 on: October 01, 2015, 09:32:40 PM »
I am actually getting a pop-up whenever I start (I've rebooted 3 times  :-\).  I can't figure out how to add the image of the pop-up but here's what it says:

   ERROR
   Couldn't establish communications with iSpy. Error 1.
   Try restarting  your computer and/or running
   Espionage.  EspionageHelper will quit now.

zsolt

  • Global Moderator
  • Veteran
  • *****
  • Posts: 823
    • View Profile
Re: anyone seeing any issues after upgrading to El Capitan?
« Reply #5 on: October 02, 2015, 05:49:25 AM »
Hello, the error you mention is Espionage 2 related. You did not completely uninstall it.

You can manually remove all the files, here is a list:
Note that some files are in your home Library folder and some in your root Library folder. Your home Library folder is hidden since Lion, to enter into it from Finder, switch to Finder, hold down the option key and select Library from the list of "places to go".:

/Users/[your username]/Library/Application Support/Espionage
/Users/[your username]/Library/LaunchAgents/com.taoeffect.EspionageHelper.plist
/Users/[your username]/Library/Services/EspionageMenu.service (might not exist)
/System/Library/Extensions/iSpy.kext
/Library/iSpy
/Library/LaunchDaemons/com.taoeffect.ispyd.plist
/Library/LaunchDaemons/com.taoeffect.Espionage.plist (might not exist)
/Library/PrivilegedHelperTools/com.taoeffect.Espionage (might not exist)

once you removed the files/folder, please reboot your Mac

Let me know if you get stuck.

Zsolt
Follow @espionageapp on twitter for news! | For general Mac support, please visit Mac Me Support

wimax

  • Newbie
  • **
  • Posts: 2
    • View Profile
Re: anyone seeing any issues after upgrading to El Capitan?
« Reply #6 on: October 02, 2015, 02:58:19 PM »
Oh, I see.  Well, thank you for assisting Zsolt.

The only files I could find and delete were:

/System/Library/Extensions/iSpy.kext
/Library/iSpy
/Library/LaunchDaemons/com.taoeffect.ispyd.plist

I can't seem to figure out how to do that trick you are mentioning about holding down the option key.  When do I hold it down and where is "places to go"?  Sorry.

NEVERMIND!  I Googled how to find this folder and found a helpful link (see below) then I was able to remove the first 3 files you mention and I'm fine now.  Thank you again.
http://www.macworld.com/article/2057221/how-to-view-the-library-folder-in-mavericks.html 
« Last Edit: October 02, 2015, 03:06:24 PM by wimax »

Teapot6761

  • Script Kiddie
  • ***
  • Posts: 6
    • View Profile
Re: anyone seeing any issues after upgrading to El Capitan?
« Reply #7 on: January 22, 2016, 05:09:31 AM »
I'm also having this problem:
ERROR
   Couldn't establish communications with iSpy. Error 1.
   Try restarting  your computer and/or running
   Espionage.  EspionageHelper will quit now.

I've tried deleting the files suggested by zsolt as above, but could only find some of them.  I've rebooted 3 times and still get this same message.  Any ideas what I can try to get Espionage working for me again?  Thank you!

Edited to add:  I tried reinstalling it but still getting error messages :/
« Last Edit: January 22, 2016, 05:16:08 AM by Teapot6761 »

zsolt

  • Global Moderator
  • Veteran
  • *****
  • Posts: 823
    • View Profile
Re: anyone seeing any issues after upgrading to El Capitan?
« Reply #8 on: January 22, 2016, 06:06:11 AM »
Hello,

can you please open terminal and paste each of the following commands one by one and hit enter after each one, then send me the complete output.

cd
ls -l ./Library/Application Support/Espionage
ls -l ./Library/LaunchAgents/com.taoeffect.EspionageHelper.plist
ls -l ./Library/Services/EspionageMenu.service
ls -l /System/Library/Extensions/iSpy.kext
ls -l /Library/iSpy
ls -l /Library/LaunchDaemons/com.taoeffect.ispyd.plist
ls -l /Library/LaunchDaemons/com.taoeffect.Espionage.plist
ls -l /Library/PrivilegedHelperTools/com.taoeffect.Espionage

and note, once you removed the files, you do not reinstall. Espionage 2 will not work with OS X Maverick or newer, you will have to use Espionage 3 if you want to protect your files.

Rgds
Zsolt
Follow @espionageapp on twitter for news! | For general Mac support, please visit Mac Me Support

Teapot6761

  • Script Kiddie
  • ***
  • Posts: 6
    • View Profile
Re: anyone seeing any issues after upgrading to El Capitan?
« Reply #9 on: January 22, 2016, 12:19:52 PM »
Last login: Fri Jan 22 08:13:12 on ttys000
Wendys-iMac-6:~ wendyasea$
Wendys-iMac-6:~ wendyasea$ cd
Wendys-iMac-6:~ wendyasea$ ls -l ./Library/Application Support/Espionage
ls: ./Library/Application: No such file or directory
ls: Support/Espionage: No such file or directory
Wendys-iMac-6:~ wendyasea$ ls -l ./Library/LaunchAgents/com.taoeffect.EspionageHelper.plist
-rw-r--r--  1 wendyasea  staff  549 Jan 22 00:09 ./Library/LaunchAgents/com.taoeffect.EspionageHelper.plist
Wendys-iMac-6:~ wendyasea$ ls -l ./Library/Services/EspionageMenu.service
total 0
drwxr-xr-x@ 7 wendyasea  admin  238 Jan  9  2014 Contents
Wendys-iMac-6:~ wendyasea$ ls -l /System/Library/Extensions/iSpy.kext
total 0
drwxr-xr-x@ 5 root  wheel  170 Jan 22 01:13 Contents
Wendys-iMac-6:~ wendyasea$ ls -l /Library/iSpy
total 344
-rw-r--r--@ 1 root  wheel    1158 Aug  2  2013 Readme.rtf
-rwxr-xr-x@ 1 root  wheel  170832 Aug  2  2013 ispyd
Wendys-iMac-6:~ wendyasea$ ls -l /Library/LaunchDaemons/com.taoeffect.ispyd.plist
-rw-r--r--@ 1 root  wheel  548 Aug  2  2013 /Library/LaunchDaemons/com.taoeffect.ispyd.plist
Wendys-iMac-6:~ wendyasea$ ls -l /Library/LaunchDaemons/com.taoeffect.Espionage.plist
ls: /Library/LaunchDaemons/com.taoeffect.Espionage.plist: No such file or directory
Wendys-iMac-6:~ wendyasea$ ls -l /Library/PrivilegedHelperTools/com.taoeffect.Espionage
ls: /Library/PrivilegedHelperTools/com.taoeffect.Espionage: No such file or directory
Wendys-iMac-6:~ wendyasea$

zsolt

  • Global Moderator
  • Veteran
  • *****
  • Posts: 823
    • View Profile
Re: anyone seeing any issues after upgrading to El Capitan?
« Reply #10 on: January 22, 2016, 09:40:18 PM »
OK, sorry, I could have write the commands better, some errors are due to space in the path, and some folders do not contain files, just subfolders and the output is somewhat confusing, but if I'm not mistaken, some of those files are present...
./Library/LaunchAgents/com.taoeffect.EspionageHelper.plist
./Library/Services/EspionageMenu.service
/System/Library/Extensions/iSpy.kext
/Library/iSpy
/Library/LaunchDaemons/com.taoeffect.ispyd.plist

so this is what you have to delete, to open a folder in the finder, if you do not want to navigate using Finder, (because user Library folder is hidden) then you can paste the folder path into terminal preceded with open command and when you hit enter, it will open that folder in Finder, for example...fist write

cd

to go into your home folder and then simply do this for each path:

open "./Library/LaunchAgents/"

hit enter...

I hope this helps

Zsolt
Follow @espionageapp on twitter for news! | For general Mac support, please visit Mac Me Support

Teapot6761

  • Script Kiddie
  • ***
  • Posts: 6
    • View Profile
Re: anyone seeing any issues after upgrading to El Capitan?
« Reply #11 on: January 22, 2016, 09:55:36 PM »
I only had the first two on this list.  I deleted those but am still getting the same error message.  But do I understand from your previous email that I can't use Espionage 2 anyway -- that I have to have Espionage 3 for El Capitan?  And if so, is there an upgrade or do I just have to purchase Espionage3? 

zsolt

  • Global Moderator
  • Veteran
  • *****
  • Posts: 823
    • View Profile
Re: anyone seeing any issues after upgrading to El Capitan?
« Reply #12 on: January 22, 2016, 09:59:26 PM »
If you wish we can do a remote session right now, but please hurry up as it is midnight over here. For Espionage 3 we can offer you 10% discount, at the time we released it, we informed all users and offered 50% discount but that one you missed.
if you wish to do the session, go to join.me URL, download the Mac client, click on start session (leave the radio button on one time code) and send me the 9 digits you get, I will connect and clean up those files for you, but as I said, pls be quick with sending me the session number
Follow @espionageapp on twitter for news! | For general Mac support, please visit Mac Me Support

Emmanuel

  • Newbie
  • **
  • Posts: 4
    • View Profile
Re: anyone seeing any issues after upgrading to El Capitan?
« Reply #13 on: March 10, 2016, 08:21:09 AM »
Hello,

I just upgraded to El Capitan and I am facing the following issue:

1/ Setup:
- MacBook El Capitan
- Mac Mini El Capitan with Espionage (very last version through menu's check updates)
- LAN network
- Protected sparsebundle on Mac Mini's drive A
- Mac Mini's drive A root is shared with Macbook

2/ Issue:
- AFP protocol share, Espionage drive closed => sparsebundle + every files/folders appear on both Mac Mini and Macbook
- AFP protocol share, Espionage drive opened  => mounted disc appears in Mac Mini's Finder (with all its content), but not on connected Macbook (other files/folders appear on both sides)
- SMB protocol share, Espionage drive closed => sparsebundle + every files/folders appear on both Mac Mini and Macbook
- SMB protocol share, Espionage drive opened => mounted disc appears in Mac Mini's Finder (with all its content), but on connected Macbook when trying to browse the Mac Mini's share the Finder hangs, cannot be restarted and in the end I have to force restart OS X with the alim button

=> The unlocked Espionage drive cannot be accessed over the network. With AFP protocol it does not appear, with SMB the Finder crashes. Other shared folders work normally (including Time Machine). Everything was working on Mountain Lion (both MacBook + Mac Mini).

Thanks in advance for your support.
Emmanuel

zsolt

  • Global Moderator
  • Veteran
  • *****
  • Posts: 823
    • View Profile
Re: anyone seeing any issues after upgrading to El Capitan?
« Reply #14 on: March 10, 2016, 09:16:40 PM »
Hello, let me test this further, I just did with Mini on 10.10 sharing root folder over afp, and MBAir on 10.11 and it works, so it seems it is the server side which creates problems.

I will let you know my results.

Rgds
Zsolt
Follow @espionageapp on twitter for news! | For general Mac support, please visit Mac Me Support