Forums temporarily locked down! Please read!

Author Topic: anyone seeing any issues after upgrading to El Capitan?  (Read 22354 times)

zsolt

  • Global Moderator
  • Veteran
  • *****
  • Posts: 823
    • View Profile
Re: anyone seeing any issues after upgrading to El Capitan?
« Reply #15 on: March 10, 2016, 09:26:01 PM »
Yes, if the server is 10.11 then it works as you described, let me check this with the dev team.
Rgds
Zsolt
Follow @espionageapp on twitter for news! | For general Mac support, please visit Mac Me Support

Emmanuel

  • Newbie
  • **
  • Posts: 4
    • View Profile
Re: anyone seeing any issues after upgrading to El Capitan?
« Reply #16 on: March 11, 2016, 07:43:21 AM »
Thanks Zsolt for your quick reply/investigation.

Regards

greg

  • Administrator
  • Veteran
  • *****
  • Posts: 898
    • View Profile
    • http://www.taoeffect.com
Re: anyone seeing any issues after upgrading to El Capitan?
« Reply #17 on: March 14, 2016, 07:58:27 AM »
Hi Emmanuel, could you please try the suggestion described here and see if that works for you?
Follow @espionageapp on twitter for news!

Emmanuel

  • Newbie
  • **
  • Posts: 4
    • View Profile
Re: anyone seeing any issues after upgrading to El Capitan?
« Reply #18 on: March 17, 2016, 05:26:00 PM »
Hello Greg, I will give it a try when I'm back to home on the next week.

Emmanuel

Emmanuel

  • Newbie
  • **
  • Posts: 4
    • View Profile
Re: anyone seeing any issues after upgrading to El Capitan?
« Reply #19 on: March 21, 2016, 06:15:30 PM »
Hello Greg,

Just tried: the Ignore ownership on this volume checkbox is already checked. I have then tried the chmod +rwx /path/to/your/encrypted/but/unlocked/folder as advised next in your post, too.

Back to my 2nd Mac, unfortunately the Finder still goes crazy when trying to access the share. The only way to recover is hard reset.

Emmanuel

greg

  • Administrator
  • Veteran
  • *****
  • Posts: 898
    • View Profile
    • http://www.taoeffect.com
Re: anyone seeing any issues after upgrading to El Capitan?
« Reply #20 on: March 22, 2016, 12:23:05 AM »
Quote
Back to my 2nd Mac, unfortunately the Finder still goes crazy when trying to access the share. The only way to recover is hard reset.

You said that the Finder only goes crazy when connecting over SMB, but do you now see it when trying to connect over AFP (using the regular 'File Sharing'?).

If you don't, I'm afraid there's not much we can do to solve this problem anytime soon, however there may be third-party solutions like ShareTool (discontinued and now freeware, but might still get the job done), or similar.
Follow @espionageapp on twitter for news!

zsolt

  • Global Moderator
  • Veteran
  • *****
  • Posts: 823
    • View Profile
Re: anyone seeing any issues after upgrading to El Capitan?
« Reply #21 on: March 22, 2016, 05:46:34 AM »
Just to add my two cents...I was actually very surprised that this ever worked. When you connect to a shared folder, you are "mounting" the remote share onto /Volume/ folder on your local Mac. Espionage on the other hand works in a way that it mounts locally a disk image onto folder you picked as mointpoint.

Now, what you are trying to achieve is to access a local mount (the protected folder) through a remote mount (the shared folder), so no wonder it is freaking out :-)

I know this does not help you a lot and you will surely ask "but how come it worked so far", but obviously Apple did some slight changes in the AFP and SMB code which now you see the result of.

What I can offer you is to access the folder by accessing the disk image through the share and mounting it locally.

For this to work, you have to install Espionage on a local mac, share the folder in which the Espionage disk images are located (normally it is Library/Application Support/com.taoeffect3.Espionage/Data) and then import this disk image into the Local Espionage installation. Would that be interesting to you? If so, let me know and I will tell you how to do it.

Rgds
Zsolt
Follow @espionageapp on twitter for news! | For general Mac support, please visit Mac Me Support