Forums temporarily locked down! Please read!

Author Topic: Cant encrypt some folders that worked with old version  (Read 2524 times)

acuraice

  • H4X0r
  • ****
  • Posts: 21
    • View Profile
Cant encrypt some folders that worked with old version
« on: May 28, 2012, 07:15:02 PM »
I finally removed all my previous encrypted folders from the older version of espionage and am now ready to go with the newer version. the older version has been successfully uninstalled and the newer version has been successfully installed and activated(lifetime) Now when i try to add the individual folders that had previously worked perfectly with the older espionage,i immediately get an error at the end of the copying script that says " Error during copy: "DocumentRevisions -V100" couldn't be moved because you don't have permission to access "Documents" could not copy all of Users/Justin/documents see system log for more.

I found the exact file it was talking about,it is an invisible file that the folder itself has a red minus symbol on it,as all of these kinds of hidden files generally do. I checked the permissions on the folder itself and it is a system file,that's why it is hidden. I can change the permissions but usually that causes huge weird problems if you screw with stuff like that. Again thats why it is a hidden file used by the system. What the heck is going on bc im sure the older version of espionage copied that file/s as well when making the secure sparseimage of that particular folder before with no errors like this until now. Should i attempt a repair permissions command in disk utility/onyx/cocktail?? Although that usually does nothing in these situations and it always finds the same permissions corrupt or bad and says it fixed them. Has been happening on mac os x for over 10 years now. Please reply with insight on this error ,i can understand very easily what to do or whats going on. I know a lot about macs and actually repair all systems for my friends. But crap like this i am have no clue. Thank you in advance. I hope this gets fixed or it will be useless to me if i cant encrypt my documents folder,which has all of my important everything!!!
update: i just successfully encrypted my entire iTunes folder as i did with the older espionage and it seems to be working as it should without that permissions error. maybe its just something specific to the documents folder,although there are a ton of those "-V100" folders on the system,i am sure i will run into this problem again while continuing to encrypt the rest of the folders i want to.

also how do you set the individual settings and passwords for each individual folder chosen?? i loved the way the old one had different settings for each. there is no way to set the encryption method with this 3.0 version,before i choose from 128-256 bt and could set whatever passwords i wanted to. Now it only lets you create a group of folders which sounded like the same thing except again no way to set the security level(128/256 bt) and it wont let me use my same password for all of them.
« Last Edit: December 31, 1969, 11:00:00 PM by Guest »

acuraice

  • H4X0r
  • ****
  • Posts: 21
    • View Profile
Re: Cant encrypt some folders that worked with old version
« Reply #1 on: May 28, 2012, 07:18:02 PM »
one more thing...what the heck is the little icon of the anchor for??? i have looked everywhere including the useless included help file and have found nothing describing what it does. Thanks
« Last Edit: December 31, 1969, 11:00:00 PM by Guest »

acuraice

  • H4X0r
  • ****
  • Posts: 21
    • View Profile
Re: Cant encrypt some folders that worked with old version
« Reply #2 on: May 28, 2012, 07:32:22 PM »
ok so a few folders worked without the error and then it happened again with my turbo tax folder on my external drive. This time i enabled showing hidden files in the finder,and deleted the "DocumentsRevisions-V100" file from the turbo tax folder and tried to encrypt it again. This time it worked without the error! i fixed it or at least found a way around it. Perhaps it will create a new DocumentsRevisions -V100 folder on its own. But as for my documents folder,the first folder that gave me that error first,i tired to delete the same V100 folder causing the problem and it didn't complete successfully. Now it says it cant be moved to the trash,after espionage did that as part of the encryption process. Hmmm...
« Last Edit: December 31, 1969, 11:00:00 PM by Guest »

acuraice

  • H4X0r
  • ****
  • Posts: 21
    • View Profile
Re: Cant encrypt some folders that worked with old version
« Reply #3 on: May 28, 2012, 07:40:07 PM »
same error "failed to trash documents,you don't have permission to trash documents folder.  This permissions shit is so annoying and has been for years and years. of course i have permission i am the owner/administrator!!! i have all passwords for all keychain info,espionage,and can even override anything the mac os tries to prevent me from doing. but fixing this small error i cannot do besides with other folders. This must be a bug with the new version. maybe it will get fixed. If not i will move all of my secure documents to another folder and encrypt that folder.
« Last Edit: December 31, 1969, 11:00:00 PM by Guest »

acuraice

  • H4X0r
  • ****
  • Posts: 21
    • View Profile
Re: Cant encrypt some folders that worked with old version
« Reply #4 on: May 28, 2012, 07:50:33 PM »
SOLVED!!!!!! the permission problem is because its a mac os x system file that cant be moved or deleted the standard way. I simply created a new folder labeled "1Documents" so it would be listed in the familiar spot in my home folder and encrypted that perfectly with the new version of espionage. Finally i have the same exact setup as i did before with the earlier version of espionage. Why ...WHY... couldn't they just have it update itself from within the older version and do all this shit automatically?????? thank God i know how to work with these computers and could figure it out way faster than the developers could have. Anyone who can benefit from this makes it all worth while. What a great way to waste my memorial day!
« Last Edit: December 31, 1969, 11:00:00 PM by Guest »

greg

  • Administrator
  • Veteran
  • *****
  • Posts: 898
    • View Profile
    • http://www.taoeffect.com
Re: Cant encrypt some folders that worked with old version
« Reply #5 on: May 29, 2012, 06:40:03 PM »
Hi acuraice, I'm happy to hear you resolved the permissions issues, yes I agree they can be a real pain sometimes... it's part of OS X's UNIX heritage, and does have its reasons & benefits though. Deleting the DocumentsRevisions-V100 folder is the correct thing to do btw.

Quote from: "acuraice"
also how do you set the individual settings and passwords for each individual folder chosen?? i loved the way the old one had different settings for each. there is no way to set the encryption method with this 3.0 version,before i choose from 128-256 bt and could set whatever passwords i wanted to. Now it only lets you create a group of folders which sounded like the same thing except again no way to set the security level(128/256 bt) and it wont let me use my same password for all of them.

The available settings can be accessed by clicking on the little 'i' (info) icon on each folder in the list. We did remove the ability to choose the encryption level to make the app easier to use. The encryption is now AES-256.

Quote
one more thing...what the heck is the little icon of the anchor for???

It's to keep the window "anchored" (visible) while you click in the background. To prevent it from fading in other words.
« Last Edit: December 31, 1969, 11:00:00 PM by Guest »
Follow @espionageapp on twitter for news!

acuraice

  • H4X0r
  • ****
  • Posts: 21
    • View Profile
Re: Cant encrypt some folders that worked with old version
« Reply #6 on: May 30, 2012, 02:08:51 AM »
Awesome! thank you for responding and thank you for making such an awesome program!!! all of my problems were solved yesterday and the app is working as intended after some minor tweaking. Dont like the way the sparse images are visible though at least on my external drive for the folders i chose to encrypt on there. However i was able to change their visibility to invisible with onyx. All problems solved.
« Last Edit: December 31, 1969, 11:00:00 PM by Guest »