Mistake while upgrading from 2.8 to 3.5

Started by joshiffm, November 13, 2013, 09:30:18 AM

Previous topic - Next topic


Hi there,
to make it short - I have a huge problem!

I had several problems accessing the content of my secured folder since updating to Mavericks. So I decided to download v3.5. When asked what to do with the program, I've chosen "replace" instead of "keep both".

Whatever I do now, the secured folder (which definitely had contend. Really important content for me) remains empty. I tried this "make visible" app but there is nothing to see... no sparse bundle, no sparseimage.

Cany anybody help to get my data back?



Hello Josh, it is a bit hard to determine exactly the state of the mess, but let's start with searching for disk images.
If we find any, then we can move one cleaning up the Espionage 2 and recovering the data, if we find none, then you decide what to do next...

Here is a terminal command which will search through your home folder, using admin privileges.
If Espionage 2 still keeps track of those folders, it might be that a prompt for password will pop up when the find command tries to enter into the folder, or if you wish, we can remove Espionage 2 first....

here are the commands (after each line, hit enter to execute it), start terminal and enter

sudo find . -name *.sparsebundle -print

note, that due to sudo command, it will ask you for your account password, you will see nothing while entering it, but that is OK, just type it in, and hit enter, and wait for find command to finish, ie. that you get back the prompt.

Let me know if it found something.

Good luck
Follow @espionageapp on twitter for news! | For general Mac support, please visit Mac Me Support


Hi Zsolt,

:) I found something... a .sparsbundle file on top level of my folder.
So I followed the next steps in the PDF guide and it worked well!

You saved my (data) life!




Be careful with data and Espionage. V3 is even more secure then V2 and make sure you do not get locked out.
Master password is all you have to remember and make regular backups, and you will be fine.

I'm glad it ended well.

In case of any questions, just let me know.

Follow @espionageapp on twitter for news! | For general Mac support, please visit Mac Me Support



Basically, the same thing happened to me...

I upgraded from OS X Mountain Lion to OS X Yosemite.  Things weren't working correctly in E2, I couldn't seem to unlock my folders, etc.  Then to make the problem worse, I downloaded the Espionage 3 trial and overwrote Espionage 2.

I have back-ups on an external drive.  I'm mostly wondering how to get Espionage 2 back up and running as I don't see a place to download it from your website.

UPDATE:  OK, I've restored E2 from time machine and it appears to be partially working as it was previously.  However, I can't successfully unlock either of the 2 folders it's protecting.  One folder it appeared to unlock for the folder is empty.  The other folder it won't even bring the password dialog box.  When I try to unlock it it just opens with the 2 folders that say "This folder contain encrypted data it is controlled by espionage do not modify it in this state".

I still the E2 back-ups on an external drive.

My understanding is that if I can't unlock these folders from E2 that I can't access them in E3?  Please help.



Don't try to make Espionage 2 work on Maverick as you will just end up in frustration. It does work sometimes, but not for everybody. My experience is that if you unlock the folder through the Espionage application then it might work, if you try to unlock it by clicking onto folder in Finder, then Finder will hang and the only way out is to reboot.

So first try to reboot, then see if you can unlock the folders through Espionage application (launch the app and manage the folder from there), once you have the content safe select uninstall from Espionage's Espionage menu.

If some of these fail, take this route:

- download the following software http://www.macupdate.com/app/mac/24682/ivisible 
- launch it, and click on "make files visible" button (in case OS X does not allow to launch ivisible, you have to go to System Preferences -> Security & Privacy, click on padlock icon in lower left corner and authenticate, then under General Tab, under "Allow apps downloaded from" select anywhere, wait for confirmation window, and then try to launch iVisible again)
- now revisit the protected folder and you will see a disk image inside, named same as the folder name, but having a dot in front of the name
- dobleclick it, it should ask you for password, enter it, and the image will mount as a volume, like for example an USB stick would mount
- open it and you will access to all your files
- copy them out, unmount the volume and delete the protected folder containing the disk image you just opened

once you have all your data back, you should uninstall Espionage 2. You can try either by selecting Uninstall option from Espionage's Espionage menu, or if that does not work, then you can manually remove all the files, here is a list:
Note that some files are in your home Library folder and some in your root Library folder. Your home Library folder is hidden since Lion, to enter into it from Finder, switch to Finder, hold down the option key and select Library from the list of "places to go".:

/Users/[your username]/Library/Application Support/Espionage
/Users/[your username]/Library/LaunchAgents/com.taoeffect.EspionageHelper.plist
/Users/[your username]/Library/Services/EspionageMenu.service (might not exist)
/Library/LaunchDaemons/com.taoeffect.Espionage.plist (might not exist)
/Library/PrivilegedHelperTools/com.taoeffect.Espionage (might not exist)

let me know if you need further help

Follow @espionageapp on twitter for news! | For general Mac support, please visit Mac Me Support


It worked on one folder and did not work on the other folder.

If we try to double click it, nothing happens.  If we right click and go to open, it gives an error:  ".Financial Records.spa image not recognized"

Here's some of the disk utility log:

2015-07-11 20:36:09 -0700: Disk Utility started.

2015-07-11 20:36:44 -0700: Verifying Image ".Financial Records.sparsebundle"
2015-07-11 20:36:44 -0700: Unable to verify ".Financial Records.sparsebundle." (image not recognized)
2015-07-11 20:36:44 -0700:
2015-07-11 20:36:55 -0700: Attach Image ".Financial Records.sparsebundle"
2015-07-11 20:36:55 -0700: Initializing...
2015-07-11 20:36:55 -0700: Attaching...
2015-07-11 20:36:55 -0700: Finishing...
2015-07-11 20:36:56 -0700: Unable to attach ".Financial Records.sparsebundle." (image not recognized)
2015-07-11 20:36:56 -0700:

Any ideas about where to go from here?


The only place to go from there is to your backup :-(

The message simply means that the operating system has problems reading that disk image as it seems to be corrupted and this is why it cannot mount it.
This might be a result of some Mac crash, or disk corruption problem. You can try to open the disk utility and if it not already there, drag the disk image into the left part of the window, once there, select it and click onto verify button, if it reports and error then you can try to run repair on it. The chances are slim, but maybe you are lucky.

Other then that, you can try to fetch a copy of the disk image from you backups and see if that will open. It will be in the exactly same location in your backup target.

Follow @espionageapp on twitter for news! | For general Mac support, please visit Mac Me Support



Thank you
Thank you
Thank you
Thank you
Thank you
Thank you

:D :) ;D :) :D :) ;D :) :D


Same level of satisfaction over here :-)
I'm not sure whether you fetched it from backup or the disk utility blessed you, but if you did not do backups so far, now is the time to start :-)
Plus, Espionage 2 is not supported and not developed any more, it will also not work on Maverick onwards, so I would warmly suggest to consider upgrading to espionage 3.

Follow @espionageapp on twitter for news! | For general Mac support, please visit Mac Me Support


I just skipped over the disc utility thing and went straight for the back-up file.  It worked on the first try.  I guess the other file had somehow gotten corrupted.

You'll be happy to know I upgraded to E3 this past weekend.  Everything seems to working fine now.

Thanks for your help!!!


Follow @espionageapp on twitter for news! | For general Mac support, please visit Mac Me Support