Forums temporarily locked down! Please read!

Author Topic: ScriptManager busy, avoiding deadlock  (Read 5178 times)

nwi

  • H4X0r
  • ****
  • Posts: 13
    • View Profile
ScriptManager busy, avoiding deadlock
« on: September 13, 2009, 03:41:31 PM »
Hi,

I'm running Espionage 2.1.1 with Mac OS 10.6. The last 2 days it happened twice that Espionage stopped to respond and consequently the folders could not be encrypted and/or unencrypted. This happened again right now, I've tried opening Mail.app and it didn't open. Then I tried opening Espionage but it hung and Activity Monitor indicated that Espionage was not responding. Therefore, I've looked at the console logs and found that the EspionageHelper was not working properly:

13/09/2009 17:23:50   EspionageHelper[240]   WARN (event_handler_for_assoc:2020): ScriptManager busy, avoiding deadlock

Therefore, I've killed EspionageHelper and manually restarted it which solved the issue. However I'm wondering why this happens while I've never had such issue with Mac OS 10.5.

Any idea ?

Thanks
« Last Edit: December 31, 1969, 11:00:00 PM by Guest »

greg

  • Administrator
  • Veteran
  • *****
  • Posts: 898
    • View Profile
    • http://www.taoeffect.com
Re: ScriptManager busy, avoiding deadlock
« Reply #1 on: September 13, 2009, 05:03:10 PM »
Hi nwi,

We've noticed this problem as well in Snow Leopard and we've fixed it for the next release of Espionage (which should be arriving sometime this month), however what you can do in the meantime to limit its impact is temporarily disable the "Lock On Quit" option for all of the application associations that you have setup. You can do this from within Espionage by selecting a folder and clicking "Edit Application Associations".  You may wish to turn on your sleep/screen saver password in the Security System Preferences after doing so.

Best regards,
Greg, Tao Effect
« Last Edit: December 31, 1969, 11:00:00 PM by Guest »
Follow @espionageapp on twitter for news!

nwi

  • H4X0r
  • ****
  • Posts: 13
    • View Profile
Re: ScriptManager busy, avoiding deadlock
« Reply #2 on: September 14, 2009, 05:55:15 AM »
Hi Greg,

Thanks for responding and confirming that this is an issue which will be fixed in the next release.
I'm looking forward to updating my version.

Regards
nwi
« Last Edit: December 31, 1969, 11:00:00 PM by Guest »

nwi

  • H4X0r
  • ****
  • Posts: 13
    • View Profile
Re: ScriptManager busy, avoiding deadlock
« Reply #3 on: September 18, 2009, 06:24:10 PM »
I've now updated to 2.5 and will monitor it for a number of days to see if this issue happens again.

Regards
nwi
« Last Edit: December 31, 1969, 11:00:00 PM by Guest »

greg

  • Administrator
  • Veteran
  • *****
  • Posts: 898
    • View Profile
    • http://www.taoeffect.com
Re: ScriptManager busy, avoiding deadlock
« Reply #4 on: September 20, 2009, 05:23:20 PM »
Hey nwi,

Just fyi, you'll never see that message in the console again as in 2.5 that code has been completely removed & rewritten. ;-)

Cheers,
Greg, Tao Effect
« Last Edit: December 31, 1969, 11:00:00 PM by Guest »
Follow @espionageapp on twitter for news!

nwi

  • H4X0r
  • ****
  • Posts: 13
    • View Profile
Re: ScriptManager busy, avoiding deadlock
« Reply #5 on: September 20, 2009, 07:58:21 PM »
Ok thanks greg.

Regards
nwi
« Last Edit: December 31, 1969, 11:00:00 PM by Guest »