Forums temporarily locked down! Please read!

Author Topic: password doesn't work anymore?!  (Read 5805 times)

iloving

  • Script Kiddie
  • ***
  • Posts: 8
    • View Profile
password doesn't work anymore?!
« on: July 23, 2012, 08:14:54 PM »
After having used espionage successfully for a couple months now, I tried unlocking my folders today only to find that my master password was being rejected!  

I tried following some instructions I found regarding renaming the Espionage folder in Application Support, but the part regarding re-adding the previous folders didn't work.  For now I have restored my previous settings, but this has screwed me right up.

Recently (during the past week) I have:
- run disk utility which found a couple of volume errors
- reset my NVRAM because my trackpad was acting a bit odd (turns out it was probably just the heat)
- Updated my copy of parallels.

I don't know if any of the above is even relevant, but I can't think of what could have caused this to happen.

Any help would be appreciated because I have some important stuff in those folders that I need access to asap.
« Last Edit: December 31, 1969, 11:00:00 PM by Guest »

zsolt

  • Global Moderator
  • Veteran
  • *****
  • Posts: 823
    • View Profile
Re: password doesn't work anymore?!
« Reply #1 on: July 23, 2012, 08:32:11 PM »
Hello re adding the folders in V3 is not that easy as you do not know the password for the disk images, unless you copied it out upfront at the time it worked fine.
So we first need to make it unlock, please do not reinstall or delete anything.

If possible, bring all back into state before you started to rename things.
The important file is the one in your Library/Application Support/com.taoeffect.... folder, there will be a file called database3. There will be more of these in the Backup subfolder.

What you have to do is:
- quit espionage using the padlock menu item
- pick one of the database3 file from the Backup folder, copy it into parent folder so that it is in Library/Application Support/com.taoeffect.... folder, start Espionage, then try to unlock it.
Note that you need to use the master password which was active at the time when that copy of the database was in use, this is in case you were chaining the password.

Whenever you try to unlock espionage (and it fails) copy the system.log messages showing that attempt, with a note which database3 did you try in that particular attempt.

Then send me those messages if you do not manage to unlock it.
Note that sometimes it takes up to 10-15 seconds for Espionage to unlock, so give it some time.

Let me know how it went.

Rgds
Zsolt
« Last Edit: December 31, 1969, 11:00:00 PM by Guest »
Follow @espionageapp on twitter for news! | For general Mac support, please visit Mac Me Support

iloving

  • Script Kiddie
  • ***
  • Posts: 8
    • View Profile
Re: password doesn't work anymore?!
« Reply #2 on: July 23, 2012, 09:21:43 PM »
I do not have a com.taoeffect... folder under Application Support. I do have an Espionage folder though.  I tried following your suggestions there.  When I try to unlock, I get the following in my system log:

12-07-23 5:16:32.410 PM Espionage: ERROR (-[DBMaster getSubDBWithPassword:error:]:127): failed because: !data

I have this problem no matter which database3 file I've tried. I've tried the original and several backups, going right back to the earliest one I had.
« Last Edit: December 31, 1969, 11:00:00 PM by Guest »

iloving

  • Script Kiddie
  • ***
  • Posts: 8
    • View Profile
Re: password doesn't work anymore?!
« Reply #3 on: July 25, 2012, 02:14:37 AM »
Bump?  I'm still having the problem.
« Last Edit: December 31, 1969, 11:00:00 PM by Guest »

zsolt

  • Global Moderator
  • Veteran
  • *****
  • Posts: 823
    • View Profile
Re: password doesn't work anymore?!
« Reply #4 on: July 25, 2012, 06:10:18 AM »
Hello, would it be possible to have a remote session so that I can take a look into this with you?
Let me know when are you earliest available.

Rgds
Zsolt
« Last Edit: December 31, 1969, 11:00:00 PM by Guest »
Follow @espionageapp on twitter for news! | For general Mac support, please visit Mac Me Support

iloving

  • Script Kiddie
  • ***
  • Posts: 8
    • View Profile
Re: password doesn't work anymore?!
« Reply #5 on: July 25, 2012, 04:48:01 PM »
Quote from: "zsolt"
Hello, would it be possible to have a remote session so that I can take a look into this with you?
Let me know when are you earliest available.

Rgds
Zsolt

By all means!  When and how?
« Last Edit: December 31, 1969, 11:00:00 PM by Guest »

zsolt

  • Global Moderator
  • Veteran
  • *****
  • Posts: 823
    • View Profile
Re: password doesn't work anymore?!
« Reply #6 on: July 25, 2012, 07:38:52 PM »
I'm available now for next hour, and same time tomorrow. Just mail me when ready.
Rgds
Zsolt
« Last Edit: December 31, 1969, 11:00:00 PM by Guest »
Follow @espionageapp on twitter for news! | For general Mac support, please visit Mac Me Support

iloving

  • Script Kiddie
  • ***
  • Posts: 8
    • View Profile
Re: password doesn't work anymore?!
« Reply #7 on: August 07, 2012, 08:23:09 PM »
Just FYI, I was having multiple other problems with the machine, and I ended performing a complete reinstall of the OS and restoring from backups.  For now I'm going to assume that some kind of corruption occurred.  I will let you know if the issue happens again.
« Last Edit: December 31, 1969, 11:00:00 PM by Guest »

mike115

  • Newbie
  • **
  • Posts: 1
    • View Profile
Re: password doesn't work anymore?!
« Reply #8 on: August 08, 2012, 09:19:34 AM »
Hi,

I am desperate for help. My password doesn't work any more. Have tried the above method to no avail.

I am happy for you to have a look remotely or mail me mike115@me.com

Mike
« Last Edit: December 31, 1969, 11:00:00 PM by Guest »

zsolt

  • Global Moderator
  • Veteran
  • *****
  • Posts: 823
    • View Profile
Re: password doesn't work anymore?!
« Reply #9 on: August 08, 2012, 08:13:23 PM »
Hello MIke,

We can do a remote session if you wish, I will be available most of the day tomorrow, I'm in GMT+2 time zone, like paris/rome/berlin.

Can you please open the console and try to unlock the Espionage again, then copy me the errors from the console messages.

Also, just to be sure, you are talking about master password, ie. you cannot unlock espionage and not the folder password, i.e. that you cannot unlock a protected folder, correct?

Please mail me to taoeffect@macmesupport.com and let me know the time is suites you for remote session, it will be better then to communicate through this forum.

Rgds
Zsolt
« Last Edit: December 31, 1969, 11:00:00 PM by Guest »
Follow @espionageapp on twitter for news! | For general Mac support, please visit Mac Me Support

rramdin

  • Newbie
  • **
  • Posts: 1
    • View Profile
Re: password doesn't work anymore?!
« Reply #10 on: August 31, 2012, 09:26:13 PM »
I think I'm also having this error. This is the message I'm getting:

Aug 31 17:22:41 robby-mbp Espionage[8993]: ERROR (-[DBMaster getSubDBWithPassword:error:]:140): failed because: !data

Does this mean I used the wrong password or is it indicative of a problem?
« Last Edit: December 31, 1969, 11:00:00 PM by Guest »

iloving

  • Script Kiddie
  • ***
  • Posts: 8
    • View Profile
Re: password doesn't work anymore?!
« Reply #11 on: September 18, 2012, 07:21:17 PM »
The problem has happened again, and this time I'm sure I'm not goofing up the password.  I get the below errors in the log.  How should we proceed?

12-09-18 3:15:03.653 PM Espionage: ERROR (-[NSData(TECrypto) decrypt:]:131): scryptdec_buf returned: 9
12-09-18 3:15:03.653 PM Espionage: ERROR (+[DBSubdb subdbWithData:master:pass:error:]:45): failed because: !decrypted
« Last Edit: December 31, 1969, 11:00:00 PM by Guest »

zsolt

  • Global Moderator
  • Veteran
  • *****
  • Posts: 823
    • View Profile
Re: password doesn't work anymore?!
« Reply #12 on: September 19, 2012, 08:10:20 AM »
Hello, pls download this custom build
http://www.taoeffect.com/other/Espionag ... 9-fix1.zip
quit Espionage, rename it to Espionage-orig copy the one you downloaded into Application folder and launch it, then try to unlock the folder again.
Let me know if it did not work,

Rgds
Zsolt
« Last Edit: December 31, 1969, 11:00:00 PM by Guest »
Follow @espionageapp on twitter for news! | For general Mac support, please visit Mac Me Support

iloving

  • Script Kiddie
  • ***
  • Posts: 8
    • View Profile
Re: password doesn't work anymore?!
« Reply #13 on: September 19, 2012, 12:37:34 PM »
Thank you, that worked.  
May I ask what that did?  
Is there something I may have done to cause this?
« Last Edit: December 31, 1969, 11:00:00 PM by Guest »

zsolt

  • Global Moderator
  • Veteran
  • *****
  • Posts: 823
    • View Profile
Re: password doesn't work anymore?!
« Reply #14 on: September 19, 2012, 01:06:46 PM »
No, it is an error we did not find yet the reason for, and this custom builds does a different kind of verification so that it is not affected by the problem.
You did nothing wrong :-)

I'm glad it worked,

Zsolt
« Last Edit: December 31, 1969, 11:00:00 PM by Guest »
Follow @espionageapp on twitter for news! | For general Mac support, please visit Mac Me Support