Forums temporarily locked down! Please read!

Author Topic: Espionage 3 lost folder on decryption  (Read 1405 times)

Secure4me

  • Newbie
  • **
  • Posts: 2
    • View Profile
Espionage 3 lost folder on decryption
« on: October 30, 2013, 10:23:32 PM »
I upgraded to Mavericks with similar issues to others, i.e. inconsistent access to encrypted Folders. Sometimes, I could get access and other times not.

I tried to unencrypted a folder and it was deleted from the list. Following various instructions from the Forum I renamed the App Espionage3, and downloaded and installed Espionage2.

I also trashed com.taoeffect.EspionageHelper.plist and rebooted, loading Espionage2.

This allows me to drag any sparsbundle folders to create a new folder list. Except, that it recognizes the folders as encrypted, and does not want to accept the password that I have used for many months. Please take it as given that I have not forgotten the password or made typos!

Why will it not accept my LONG established and used password? Is the accessing password to Espionage different from the underlying files?

Added comments:
I should add that the other 2 folders that were originally part of the Espionage 3 configuration are still accessible using the same old password.

And, having located the now 'delisted' sparsebundle folder, it does not matter if I try to double click it, or drag it into Espionage 2 or 3, it rejects the password that previously worked for all three folders.

The file is there, but inaccessible.

Please advise.
 
« Last Edit: November 01, 2013, 12:31:15 AM by Secure4me »

zsolt

  • Global Moderator
  • Veteran
  • *****
  • Posts: 823
    • View Profile
Re: Espionage 3 lost folder on decryption
« Reply #1 on: November 01, 2013, 11:12:53 AM »
Hello, it is a bit hard to follow what you write.

Can you please answer the following:
- do you have both espionage2 and 3 running, if not, can you make them run, i.e. does each of them start properly?
- do you have any folders protected by Espionage 2 and Espionage 3?
- what is your goal, do you want to continue to use Espionage 2, or do you want to migrate to Espionage 3 or something else?
- which data you cannot access, the one which was/is protected by Espionage 2 or 3?

Thanks
Zsolt
Follow @espionageapp on twitter for news! | For general Mac support, please visit Mac Me Support

Secure4me

  • Newbie
  • **
  • Posts: 2
    • View Profile
Re: Espionage 3 lost folder on decryption
« Reply #2 on: November 01, 2013, 06:51:32 PM »
Fair comment. I tried to write about the steps I had already taken.

Nonetheless, I have now recovered ALL data.  :) :)

For whatever reason, the folders still don't like opening "reliably" in ES 3 though with persistence they do. It appears that I need to open them all, sequentially, for some reason.

Perhaps they are too large, or they don't like OSX Mavericks?

How did I recover them? Using your instructions (see below) and from backups. They must have been missing critical information in the database3 file.

I'm happy now, but until I understand why ES3 has difficulty opening the folders I can't risk keeping them encrypted with ES3.

(My prior attempt to recover them using ES2 is a red herring, i.e. has no bearing on the issue.)

_________________________________________
In the POST: Espionage 3 lost a folder?!!!

Your Response to the question:

One thing we can try is the following:
Inside your Library/Application Support/Espionage/Backups there are backups of database3. This is the database which contains information about the passwords and disk images. There is also one file named database3 in the Espionage folder directly. Please quit espionage 3, rename the database3 file into database3-newest or something like that, and then take one older copy from the backup folder and move it into Espionage i.e. parent folder, and rename it to database3.
Then try to start Espioanage again and see if the folder appears. Do this one file at the time going from newest toward older.

zsolt

  • Global Moderator
  • Veteran
  • *****
  • Posts: 823
    • View Profile
Re: Espionage 3 lost folder on decryption
« Reply #3 on: November 02, 2013, 06:57:01 AM »
Hello, I'm still not sure what went wrong there at you, but if you wish, we can give it another try in a remote session and then you can ask all the questions you want, and we can see if we run into any problem encrypting some test folders.
I will be available most of the day today and tomorrow, just mail me at taoeffect@macmesupport.com with the time it suites you. Note that I'm in GMT+1 time zone.

RGds
Zsolt
Follow @espionageapp on twitter for news! | For general Mac support, please visit Mac Me Support