Forums temporarily locked down! Please read!

Author Topic: Cannot add folder  (Read 1229 times)

kfr

  • Newbie
  • **
  • Posts: 2
    • View Profile
Cannot add folder
« on: July 01, 2013, 02:49:24 PM »
Just bought the software. Tried to add a folder by using "drag a folder here".  It's not working. Getting the following message: "Error creating disk image. Failed to create disk image, error: hdiutil: create failed - Resource busy"

I can run hdiutil from command line and create an image using the same folder I tried to add to espionage. Any solution or should I consider the software won't work on my machine running OS X 10.8.5 (12F13)?

greg

  • Administrator
  • Veteran
  • *****
  • Posts: 898
    • View Profile
    • http://www.taoeffect.com
Re: Cannot add folder
« Reply #1 on: July 01, 2013, 04:25:15 PM »
Hi kfr,

- Did you try restarting and trying again?
- Do you have any antivirus software installed?
- Do you have DriveGenius installed (and have you enabled the DrivePulse feature)?
Follow @espionageapp on twitter for news!

kfr

  • Newbie
  • **
  • Posts: 2
    • View Profile
Re: Cannot add folder
« Reply #2 on: July 01, 2013, 08:27:42 PM »
Thank you! DriveGenius was the cause. Problem solved.
Now another problem: chown some subdirectory of the newly added directory to a different user doesn't work. Any way to make it work?
That question probably relates to earlier questions asked about mysql. mysql expects the directory where the SQL data resides to be owned by user "mysql" from group "mysql"

Thanks,

greg

  • Administrator
  • Veteran
  • *****
  • Posts: 898
    • View Profile
    • http://www.taoeffect.com
Re: Cannot add folder
« Reply #3 on: July 01, 2013, 09:55:11 PM »
- In the Finder, open the unlocked encrypted folder so that you're looking inside of its contents.
- Make sure that no files or folders are selected by clicking on the white background once (to deselect anything that's selected).
- Press Command-I, or choose "Get Info..." from the File menu

At the very bottom you'll see a section for "Sharing & Permissions". If you don't see any details under it then click on the little gray triangle next to "Sharing & Permissions". You should see a checkbox at the bottom that says "Ignore ownership on this volume." Make sure it's unchecked. If the little lock icon down there is locked, click it to unlock it (you'll be prompted for your computer's administrator password), and then you'll be able to uncheck the checkbox.

After unchecking that box you should be able to change the ownership on files and folders.

If you have any other questions don't hesitate to send us a reply.
Follow @espionageapp on twitter for news!