All folders are getting Critical Alert and not mounting

Started by artisfun, October 08, 2013, 12:24:42 AM

Previous topic - Next topic


Environment...OSX 10.7.5, Espionage 2.8.13

Recently shutdown and one of the folders under Espionage was open.  The expectation is the folder would be properly closed.
But once back up, none of the folders under Espionage will open.  Did remove one folder from Espionage but got the same error messages.  But the folder is gone from the list in Espionage and the folder on the os side is now .xxx.sparsebundle. 
There are backups of the folders but of course the one that was open will not be current.  Are those updates now lost?

Appears the info about Espionage 2 is no longer on your website, at least I could not find.  So really cannot work this out alone.  I've got the system message/console message is that would help.

Growl displayed messages are:
Critical Alert!
Failed to mount image for 'xxxxx'
Check the log (see Espionage Help menu) for more info.

Critical Alert!
Couldn't unlock 'xxxxx' because the image failed to mount!

Sample message from the console...
10/7/13 10:46:02.826 PM System Preferences:        mountable disk appeared: /Volumes/EspionageMounts/nb/3790953693/HiPri
10/7/13 10:46:02.828 PM System Preferences:        Disk Image found and ignored: disk6s2 /Volumes/EspionageMounts/nb/3790953693/HiPri
10/7/13 11:06:00.087 PM EspionageHelper: ERROR (-[NSFileManager(TEAdditions) moveFile:toDirectory:]:43): rename resulted in: 30
10/7/13 11:06:00.088 PM EspionageHelper: ERROR (mountImageForRecordWithPassword:702): couldn't move image: /Volumes/Exp/HiPri/.HiPri.sparsebundle
10/7/13 11:06:00.088 PM EspionageHelper: INFO: Posted critical message: Failed to mount image for 'HiPri'
Check the log (see Espionage Help menu) for more info.
10/7/13 11:06:00.139 PM EspionageHelper: ERROR (unlockRecordWithPassword:1682): failed to unlock (/Volumes/Exp/HiPri): Couldn't unlock 'HiPri' because the image failed to mount!
10/7/13 11:06:00.139 PM EspionageHelper: INFO: Posted critical message: Couldn't unlock 'HiPri' because the image failed to mount!
10/7/13 11:06:00.146 PM EspionageHelper: ERROR (-[UnlockRecordTask runTask]:77): Failed to unlock: /Volumes/Exp/HiPri
10/7/13 11:06:00.148 PM EspionageHelper: ERROR (event_handler:496): handler failed to unlock: /Volumes/Exp/HiPri

These messages are occurring for all folders under Espionage when attempting to open with password or remove from Espionage.

I did find, using the Terminal app, under the /Volumes/EspionageMounts/nb/3790953693 there are two folders still there.  Is that where my last updates would reside?



It does not look good.
All I can say is to try to mount the disk images using terminal.
First, try to find all of them on your mac:
- launch terminal and run


hit enter, then

sudo find . -name *.sparsebundle -print

it will ask you for your account password, just type it in, there will be no characters printed on the screen, once done, just hit enter. This will allow the find command to enter into all folders.

It will list each disk image it finds.
say, something like this:

./Library/Application Support/Adium 2.0/.Adium 2.0.sparsebundle

now, write

open "./Library/Application Support/Adium 2.0/.Adium 2.0.sparsebundle"

note the quotes at the beginning and at the end of the path, this is required if the path has spaces in it, just like the example does.

This will attempt to open the disk image, if all fine, it should ask you for password, enter it and if it does not report an error then write into another terminal window


it will list you all the mounted volumes, somethin like:

/dev/disk1s2 on /Volumes/EspionageMounts/zmagyar/4253459077/Thunderbird (hfs, local, nodev, nosuid, journaled, noowners, mounted by zmagyar)

now write

open "/Volumes/EspionageMounts/zmagyar/4253459077/Thunderbird" and it should show you the content of the disk image i.e mounted volume in the finder...

give it a try and let me know how it went

Follow @espionageapp on twitter for news! | For general Mac support, please visit Mac Me Support


First,  ;D

Second here is briefly what happened..

Ran the find command on the external drive which holds the folders and the Espionage backups.  The only folder with a .sparsebundle suffix was the one folder, Art, which had been removed from Espionage but indicated Failure with the Critical Alert.  The one folder had a path of /Volumes/Exp/Art/.Art.sparsebundle.   All the other folders had a path of /Volumes/Exp/xxxxx and each would request a password which resulted in a Critical Alert message.

Ran the open command on the Art folder, password accepted, the folder appeared on the Desktop, and a Finder window opened showing the contents of the folder. Yeah!
The mount command was not used since the folder appeared on the Desktop.

So, one by one, I removed the folders from Espionage and then ran the open command.  The folder which I thought I'd lose the updates has all the current info.

So happy.

What do I do next?


Well, if you have all your data back, it is up to you if you want to add them again back to Espionage or not.
If you do, then I suggest you to uninstall Espionage 2 and upgrade to Espionage 3, and we will stop supporting Espionage 2 at the end of this year.
At the moment there is a promotion running at so you can grab it for a good price.

If I misunderstood you, pls let me know.

Follow @espionageapp on twitter for news! | For general Mac support, please visit Mac Me Support


I don't know what to do with .sparsebundle files.  When adding into Espionage, the files are usually in their original state of being a regular folder, not a sparsebundle.   Are you saying that the folders can be added into Espionage as already .sparsebundle?

I'll be consolidating to osx 10.9 when it comes out and then solely using Espionage 3.  Right now, I'm drifting between osx 10.6.8 and 10.7.5. However, due to this scare, will stop using Espionage 2 on osx 10.7.5 and use E2 solely on 10.6.8.

Still looking for directions on what to do with the .sparsebundles.


Hello, if I understood you correct, then you managed to open all sparse bundles using the terminal procedure I sent you. If you did, then you could copy all the data out of them into regular folder. If you did, then just delete the sparsebundle files, they are just duplicate of your data in another form.

If you did not manage to open all the sparsebundles, due to an error, adding them back to espionage will not help either, as espionage will try to unlock them in the same way as you tried using terminal.

If you want to add your data back to Espionage, just drag the regular folder into it, it will encrypt again and you are good to go.

However, if you plan to upgrade to Espionage 3, then do not bother to add the data back to Espionage 2 again, instead, uninstall Espionage 2 by launching it, unlocking it and then selecting uninstall from the Espionage menu. THis will properly uninstall all the background processes too.

Then install Espionage 3 and add the folders to it.

Follow @espionageapp on twitter for news! | For general Mac support, please visit Mac Me Support


Basically, here is what happened after recovering access to the folders under Espionage.

Logged into 10.6.8 which is running Espionage 2.8.13 and the folders were all back under Espionage without doing anything else.  Magic!

Now in the process of moving everything to 10.9 and Espionage 3.x.

Thanks for all your help.