Tao Effect Forums

Espionage => Espionage 3 => Topic started by: Alison on December 09, 2016, 11:09:24 PM

Title: Critical Error - Failed to Unlock!
Post by: Alison on December 09, 2016, 11:09:24 PM

Can somone help me solve this issue?

OS Version - macOS Sierra 10.12.1

Running latest version of Espionage.

Have no background apps such as virus protection running.

I have a USB Thumbdrive which is formatted to Journaled, Encrypted.
USB thumbdriver is unlocked, folder inside named "Untitled"
Place folder into Espionage which encrypts and places old one into trash.
Folder is locked.
Ask Espionage to unlock and shows "Critical Error: Failed to unlock "untitled folder" failed to mount disk image, error"
The .sparsebundle is located in macOS Documents folder and directing to folder under preferences correctly.

Espionage will decrypt the folder back, just can't use it to mount once folder has been encrypted.

Anyone offer some help?
Title: Re: Critical Error - Failed to Unlock!
Post by: zsolt on December 11, 2016, 10:34:29 AM
Hello, this is probably a known issue, but let me clarify it a bit further:
- you protected a folder which was originally on this USB stick but decided to put the sparseundle into your startupdisk/Documents folder?
This does not make much sense, because I guess the reason you encrypted the folder on the USB stick is to be able to detach this folder from the Mac (for security reasons I guess).
The sparsebundle is the "file" which actually holds the data, so it would make more sense to keep that on the USB stick.


now to the problem: it is the mountpoint folder which makes problems here, this is a known issue under Sierra, the workaround is to put the mountpoint folder onto internal disk.

So if I got it all right, then this is to do:
- create a folder named "untitled folder" inside your Documents folder
- unlock espionage
- click onto small "i" near the folder name in Espionage folder list, this will take you to the folder options window
- use the disk image drop down menu to move the sparse bundle onto USB stick
- use the mount point drop down menu to select the folder you created on your internal disk
After this is done, it should start to work normally

let me know how it went,
Title: Re: Critical Error - Failed to Unlock!
Post by: cwhalen on February 04, 2017, 06:02:22 PM

Just ran into the same problem. The fix worked for a folder with one file, but when I tried to put in multiple files it did not work. I don't have a memory problem.

I used Espionage 2 and never had a problem with the setup or implementation. It always worked as advertised - great job. Not so with Espionage 3.

From a user experience why should we (as a user) care about or even have to bother to understand a mount point? I have a folder which I wish to secure, so I purchase software to do just that. Isn't that your job to secure it without having the user become engaged in paths (mount points) etc. Just secure the folder. If you need a mount point folder or whatever, just create it....you're already creating other files without asking the me.

Additionally the Espionage 3 does not secure files on external drives (OSX Sierra) without having to go through a convoluted reset of different folders from a special "information" icon within Espionage. Seriously, the software fix to this problem was to create an info box, where the use again has to engage again with special file placements of bundles etc.

Sorry to be ragging on your software but you could do better, you proved that with version 2. This version is a step back. Please do better.

Thanks, Charles

Sorry but I'm really disappointed with this version

Title: Re: Critical Error - Failed to Unlock!
Post by: zsolt on February 04, 2017, 09:51:08 PM
Hello Charles,

Users normally do not have to understand the mountpoint folder concept, it is just due to the bug in Sierra that we are "forcing" you to understand how Espionage works so that you understand why do you have to move the mountpoint folder around.

Normally, if all works fine, the mountpoint folder will become the folder you protect, so "it just works".

Espionage 2 had mountpoint folders too, the only difference is that we kept the disk image inside the protected folder, now we keep them all in one place, inside your homefolder/Library folder, so that you do not delete it by accident.

In case of External folder protection, we do ask you where to save the disk image, but again, the mountpoint folder will be the folder you protect, unless you are runinng Sierra, where we have to use the workaround until Apple fixes it.

Thanks for your input, we took notes on your remarks,

Title: Re: Critical Error - Failed to Unlock!
Post by: cwhalen on February 04, 2017, 10:12:19 PM
Hey Zsolt

Appreciate the reply, thanks.

Since I was only securing a folder on an external HD I did not even try to secure a folder residing on the internal drive. Assumed it all worked the same with a "mountpoint" etc. Nice to know it's simple drag and drop.

So what is the Apple bug, if you don't mind sharing?

Thanks, CW
Title: Re: Critical Error - Failed to Unlock!
Post by: zsolt on February 05, 2017, 07:50:39 PM
With espionage we rely on apple's disk utility mechanism, which you can access through Disk utility application but also through the command line using the diskutil command.

If you try to mount a disk image with a specified mountpoint folder (so that it does not mount in the default /Volumes folder), and you specify a mountpoint folder which is not on the internal disk, then the mount fails.

This worked before, and it is clearly a bug because all the options are still there, it is just that they do not work properly.

So this is what we are waiting to be fixed.

If you have any further questions, just let me know,